TestCase DamBreak3D

Hi, when i run the testcase dambreak3D i found some strange things.

we can see some particles near the wall seem to be remain initial position.
then i run ./DamBreak --device 0,1 --deltap 0.0025

and i got some WARMING like this, which doesn’t show using the default options.

Anyone know why the particles near wall won’t move, and what cause these WARMING.

Dear @JoJo,

The behavior of the particles you see near the solid boundary is well known when SPH Dynamic boundary conditions are employed. Due to the methodology used to treat such type of boundary, the density evolution of the solid particles can create a pressure field that is responsible of having this behavior; some particles stuck to the solid surface. So no worries about that.

Regarding the error you see in the terminal, it seems that the splash is very strong and some particles are leaving the domain (i.e. they are not seen by the smoothing kernel anymore)… Increasing the viscosity of the fluid or the height of the domain will solve this issue.


i see thanks for reply

Hello @JoJo,

concerning the warnings, if you don’t want to change the viscosity, you could also consider increasing the speed of sound for the fluid. Usually, the speed of sound is set equal to at least 10 times the highest speed that can be developed during the simulation (we typically use 20 times). It’s likely that the finer resolution resolves faster dynamics within the splashes and makes some particles move faster, thus you need a higher speed of sound. I run the problem at your resolution and the particles around the obstacle move at around 5 m/s, so I would use at least 50 m/s as sound speed. On the other hand, consider that a higher speed of sound is paid in terms of simulation speed since the time-step becomes smaller.
I hope this solves the issue,